Note to all Keri Customers using Mercury LP1501, LP1502, LP2500, LP4502 Intelligent Controllers. These controllers will not handle leap year properly and will report date and time incorrectly after February 29th 2020. This does not affect controllers deployed in Legacy Mode….only Native Mode.  When run in EP emulation mode, they work correctly. To avoid functionality problems in systems with this equipment, you must update all LP Intelligent Controllers to firmware version 1.27.8.0629 before March 1st, 2020. For assistance, you may contact the Mercury Tech Support Team directly at: TechSupport@Mercury-Security.

Latest Articles:

Notice Regarding Mercury Security Firmware Vulnerability

Notice Regarding Mercury Security Firmware Vulnerability

Notice Regarding Mercury Security Firmware Vulnerability Mercury Security has been informed ...
Familiar with Mercury controllers? NXT-MSC uses Mercury firmware

Familiar with Mercury controllers? NXT-MSC uses Mercury firmware

Familiar with Mercury hardware? If so, then you already know how to install Keri NXT-MSC ...
The Cloud: Total Cost Of Ownership

The Cloud: Total Cost Of Ownership

Borealis - Cloud-Based Access Control Utilizing The Cloud:Total Cost of Ownership   Exploring ...
NEW: Cloud Backup & Restore Feature

NEW: Cloud Backup & Restore Feature

NEW: Cloud Backup & Restore Feature We are pleased to announce the release of our new ...

Email Us

sales@kerisys.com

Get A Free Quote

Tell us about your project